1970 Mustang Mach1 World Registry Forum

Welcome to the 1970 Mustang Mach1 World Registry this forum is open to all 1970 Mach1 owners & enthusiast around the world.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log inLog in  

Share | 
 

 fuel gauge does not registar properly

View previous topic View next topic Go down 
AuthorMessage
dearborn
Mach1 Addiction


Number of posts : 44
Registration date : 2007-08-14

PostSubject: fuel gauge does not registar properly   Fri 31 Oct - 7:41

Question Have fuel gauge that just barely moves past empty when tank has plenty of fuel in it. Did proper check by grounding out feed wire at tank and gauge went to full as it was supposed to. Removed gauge cluster to check for fuel gauge installation, that all checks out . New printed circuit board in place. Any ideas as what could be wrong.Thanks.
Back to top Go down
View user profile
1970twisterspecial
Mach1 Veteran
avatar

Number of posts : 105
Age : 46
Your location : Netherlands
Registration date : 2007-12-24

PostSubject: Re: fuel gauge does not registar properly   Fri 31 Oct - 16:25

Like you said, you've tested the gauge and wiring by grounding the wire at the sender end.
Only thing that could be wrong is the sender itself.
Back to top Go down
View user profile http://www.dutch-twister.nl
jeremy0711
Mach1 Addiction
avatar

Number of posts : 38
Age : 41
Your location : Evansville, IN.
Registration date : 2007-01-31

PostSubject: Re: fuel gauge does not registar properly   Sat 1 Nov - 10:33

check your float. another check without emptying out your tank it to:

pull off your gas filler tube. take a metal hanger and put a 90 degree bend for a few inches and the rest straight. get a flashlight and like down in the tank. it will be just to the left of where you can see in there through the tail light panel. lift it up and see what your gauge does. give it a few seconds to settle.

i put in a brand new tank and sending unit. the float went bad in two days. the floats are 5 bucks for a BRASS ONE. I had to put just a touch of wire solder to hold it in place for a piece of mind.

jeremy
Back to top Go down
View user profile
dearborn
Mach1 Addiction


Number of posts : 44
Registration date : 2007-08-14

PostSubject: new sending unit.   Mon 10 Nov - 9:48

Good day. Thanks for the replies, helped big time. Problem was the new float ball has a leak and took on gas, of course sank to bottom of the tank. I did salvage my old sending unit and used that folat.

Thanks again.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: fuel gauge does not registar properly   

Back to top Go down
 
fuel gauge does not registar properly
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» '73 fuel gauge
» Dodgy Fuel Gauge
» Fuel Gauge fitting to 1984 K100RS ... Fuel Level Senders
» Fuel gauge for 86 K100RT
» Fuel gauge

Permissions in this forum:You cannot reply to topics in this forum
1970 Mustang Mach1 World Registry Forum :: DISCUSSIONS :: Tech Discussion (Q&A), Problems, Fixes. etc..-
Jump to: