1970 Mustang Mach1 World Registry Forum

Welcome to the 1970 Mustang Mach1 World Registry this forum is open to all 1970 Mach1 owners & enthusiast around the world.
 
HomeHome  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log inLog in  

Share | 
 

 CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!

View previous topic View next topic Go down 
AuthorMessage
Shelbster
Mach1 Member
avatar

Number of posts : 16
Registration date : 2008-09-16

PostSubject: CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!   Sun 8 Mar - 12:30

I have a crazy problem...( 70-mach 1 351 cleve)

My car starts and runs, as long as i hold the key and let the starter motor
run !, as soon as i let go of the key, were normaly the engine should
stay running.... It stops !...

Im not a wire specialist but could this be the starter relay that doesnt
connect the power to the ignition when you let go of key ?

or is there a mass / ground error etc....

All wires seem oke , nothing has been changed on it sinds the last time
it ran normaly ?

Cant be carb related van it ? ( normal mech. fuel pump) and the car has
electronic ignition....

PLEASE HELP !!!

Shelbster
Back to top Go down
View user profile
seany-boy
Mach1 Veteran
avatar

Number of posts : 158
Age : 56
Your location : Australia
Registration date : 2008-07-28

PostSubject: Re: CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!   Mon 9 Mar - 8:00

Hi Shelbster,

hard to tell when I am not there listening, but I believe the ignition switch is known for having this sort of problem. When you release it it drops the power, maybe to the coil. I will ask around. You should be able to measure voltage on the coil when you have released the key back to normal position so put a multimeter on the coli and have someone check while you try to start. Electronic points also cause dumb problems in my experience Bad)

Sean
Back to top Go down
View user profile
seany-boy
Mach1 Veteran
avatar

Number of posts : 158
Age : 56
Your location : Australia
Registration date : 2008-07-28

PostSubject: Re: CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!   Mon 9 Mar - 18:38

Shelbster , this is the info I got on email .

Put a volt meter on the +ive side of coil and if a power fault he should see it drop off. Easy way to prove it, run 12v wire to +ive
side of coil, start car - if it runs then you know it's ok other than
voltage. Don't leave it more than 10 secs between connecting &
starting, then pull it as soon as you know otherwise it could hurt
points n coil because they normally drop voltage through the resistive wire.

Check small wires on solenoid are not reversed, then replace ignition
switch - repro switches do this regularly...
Back to top Go down
View user profile
Shelbster
Mach1 Member
avatar

Number of posts : 16
Registration date : 2008-09-16

PostSubject: Re: CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!   Tue 10 Mar - 6:34

Thanks seany... But found the problem...

The strarter relay is the isseu, the internal switch didnt keep the
power on when the key was released... I put a wire between
the in and output ( the two smaller wires on front of the starterrelay)
and .... Problem solved.. I can drive now , just cant stop the engine
on the key (hahaha) , but if orderded a new relay, so should be oke ?

THANKS FOR THE KIND HELP ! cheers
Back to top Go down
View user profile
seany-boy
Mach1 Veteran
avatar

Number of posts : 158
Age : 56
Your location : Australia
Registration date : 2008-07-28

PostSubject: Re: CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!   Tue 10 Mar - 6:58

excellent, just keep going until you run out of petrol Very Happy
Back to top Go down
View user profile
Shelbster
Mach1 Member
avatar

Number of posts : 16
Registration date : 2008-09-16

PostSubject: Re: CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!   Tue 10 Mar - 6:59

That wont be long with this monster...

Likes fuel as much as i like beer... Cool
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!   

Back to top Go down
 
CAR STARTS BUT KILLS OFF AGAIN AFTER KEY RELEAS!
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Engine starts fine cold, dies when warm
» By 2000 rpm around 75mph car starts shaking like crazy
» Bolt ready for another big season - starts in Rome on May 26
» My 95 riv starts for 2 sec then dies out. anyone know whats going on?
» Producer Ron Howard Starts Filming "Rush" Movie

Permissions in this forum:You cannot reply to topics in this forum
1970 Mustang Mach1 World Registry Forum :: DISCUSSIONS :: Tech Discussion (Q&A), Problems, Fixes. etc..-
Jump to: